Back to overview
Degraded

Email Issues

Sep 26 at 01:50pm BST
Affected services
Wj Fulcrum Production

Resolved
Sep 26 at 02:53pm BST

As part of our remediation efforts, we have re-configured our mail servers to route through an alternative whitelisted provider. This ensures that email notifications, including two-factor authentication (2FA) emails, should now be delivered correctly again.

We are still awaiting confirmation from Nemesis and Spamhaus regarding the removal of our domain @wj-fulcrum.co.uk from their blocklists. Once delisted, we will revert back to our primary mail server.

In the meantime, you should no longer experience issues with missing 2FA emails. We will continue to monitor the situation closely and provide further updates as necessary.

Updated
Sep 26 at 02:12pm BST

Following our investigation, we have identified that our domain @wj-fulcrum.co.uk has been listed on both Nemesis and Spamhaus. These are global spam filtering and reputation services used by many email providers to block suspected unwanted or malicious mail.

As a result, our mail server is currently being blocked by a number of external providers, which is preventing some two-factor authentication (2FA) emails from being delivered.

We have formally requested the removal of our domain from these blocklists. However, as this process can take some time and is outside of our direct control, we strongly advise all companies to whitelist emails from @wj-fulcrum.co.uk to ensure successful delivery in the meantime.

We will continue to monitor this closely and provide updates as the situation progresses. Thank you for your cooperation and patience.

Created
Sep 26 at 01:50pm BST

We are currently investigating an issue where two-factor authentication (2FA) emails are not being received. Our team is reviewing the mail delivery process to identify the cause and implement a resolution as quickly as possible.

We will provide an update once further information is available.